Рейтинг:  4 / 5

Звезда активнаЗвезда активнаЗвезда активнаЗвезда активнаЗвезда не активна
 

D-Link DGS-3620-28TC

Введение

Желание протестировать коммутатор D-Link DGS-3620-28TC в нашей тестовой лаборатории возникло из-за наличия у данной модели функции VLAN Translation. Мы уже видели реализацию данного функционала у другого производителя, однако тогда нам так и не удалось заставить его заработать. Коммутатор DGS-3620-28TC успешно справился с задачей, но обо всём по порядку.

Внешний вид

Маршрутизирующий коммутатор D-Link DGS-3620-28TC выполнен в 1U металлическом корпусе с пластиковой передней панелью и предназначен для монтажа в стойку. Габариты устройства (без учёта ушей) составляют 441х310х44 мм. Вместе с коммутатором поставляются «уши» для крепления в стойку, а также резиновые ножки для настольного размещения.

Верхняя и нижняя поверхности ничем особенным не примечательны. На боковых панелях расположена вентиляционная решётка для охлаждения устройства (направление воздушного потока не изменяемо: от одной боковой стенки до другой). Стоит, пожалуй, отметить, что уши к DGS-3620-28TC могут крепиться как ближе к передней панели, так и к задней.

На задней стороне устройства расположен разъём для подключения основного питания, а также ввод для подсоединения к резервному источнику питания постоянного тока (закрыт защитной пластинкой).

Лицевая панель несёт на себе 20 медных порта Gigabit Ethernet (с 1 по 20), также четыре комбо-порта (21-24) для подключения к медной или оптической сети, а также четыре порта SFP+ для подключения к оптическим сетям 10GE. Кроме того на передней панели расположен слот для SD-карт, разъём для подключения внешних датчиков, световые индикаторы состояния портов и всего устройства, а также консольный и управляющий интерфейсы.

Заглянем теперь внутрь корпуса.

Аппаратная платформа

Электронная начинка коммутатора DGS-3620-28TC состоит из четырёх плат: двух основных и двух вспомогательных. Вспомогательные платы выполняют функции блока питания и вывода световой индикации о состоянии портов.

Маленькая плата выполняет функции управляющего модуля, на ней основные элементы размещаются с двух сторон.

Система построена на базе одноядерного MIPS процессора Broadcom BCM53003B3KPBG, работающего на частоте 600 МГц. Блок-схема данного процессора представлена ниже.

В качестве флеш-памяти использованы два модуля Spansion S29GL512P11TFI01, объём каждого составляет 64 Мбайта, таким образом системе доступно 128 Мбайт флеш-памяти. Функции оперативной памяти выполняют два DDR2 модуля Winbond W971GG6JB-25, объём каждого равен 128 Мбайт, то есть всего 256 Мбайт оперативной памяти доступно системе.

На большой плате для коммутации используются следующие чипы Broadcom: BCM54680B0KFBG, BCM54640B0KFBG, BCM8747BKFBG и BCM56334B0KFSBG. Модуль Broadcom BCM5461SA1KPFG обеспечивает работу MGMT-порта. Работа с SD картами поддерживается чипом Realtek RTS5159.

На этом мы завершаем рассмотрение аппаратной части и переходим к изучению программной составляющей.

Обновление прошивки

Смена версии микропрограммного обеспечения может производиться с помощью командной строки или веб-интерфейса устройства. Рассмотрим сначала процедуру обновления через интерфейс командной строки. Перед началом обновления пользователю необходимо загрузить файл с новой прошивкой с сервера производителя и разместить этот файл на своём TFTP-сервере.

Выяснить текущую версию прошивки можно с помощью команды show switch.

DGS-3620-28TC:admin#sho swi
Command: show switch
Device Type : DGS-3620-28TC Gigabit Ethernet Switch
MAC Address : 84-C9-B2-1F-BE-00
IP Address : 10.90.90.90 (Manual)
VLAN Name : default
Subnet Mask : 255.0.0.0
Default Gateway : 0.0.0.0
Boot PROM Version : Build 1.00.012
Firmware Version : Build 1.00.035
Hardware Version : A1
Firmware Type : EI
Serial Number : PVXF1B8000113
System Name :
System Location :
System Uptime : 0 days, 1 hours, 22 minutes, 1 seconds
System Contact :
Spanning Tree : Disabled
GVRP : Disabled
IGMP Snooping : Disabled
MLD Snooping : Disabled
RIP : Disabled
RIPng : Disabled
DVMRP : Disabled
PIM : Disabled
PIM6 : Disabled
OSPF : Disabled
OSPFv3 : Disabled
BGP : Disabled
VLAN Trunk : Disabled
Telnet : Enabled (TCP 23)
Web : Enabled (TCP 80)
SNMP : Disabled
SSL Status : Disabled
SSH Status : Disabled
802.1X : Disabled
Jumbo Frame : Off
CLI Paging : Enabled
MAC Notification : Disabled
Port Mirror : Disabled
SNTP : Disabled
DHCP Relay : Disabled
DNSR Status : Disabled
VRRP : Disabled
HOL Prevention State : Enabled
Syslog Global State : Disabled
Single IP Management : Disabled
Password Encryption Status : Disabled
DNS Resolver : Disabled

Первое, что требуется сделать, - выгрузить файл с прошивкой на коммутатор.

DGS-3620-28TC:admin#download firmware_fromTFTP 10.90.90.92 src_file new.had dest_file c:/new.had
Command: download firmware_fromTFTP 10.90.90.92 src_file new.had dest_file c:/new.had
Connecting to server................... Done.
Download firmware...................... Done. Do not power off!
Please wait, programming flash......... Done.
Success.

Затем необходимо указать, что после перезагрузки должен быть использован именно эта версия микропрограммного обеспечения, и выполнить саму перезагрузку.

DGS-3620-28TC:admin#dir
Command: dir
Directory of /c:
Idx Info Attr Size Update Time Name
--- ------- ---- -------- ------------------- ----------------
1 RUN(b) -rw- 7182308 2000/01/01 02:06:39 new.had
2 RUN(*) -rw- 7182308 2000/01/01 02:01:38 runtime.had
3 d--- 0 2000/01/01 00:00:12 system
126002 KB total (111882 KB free)
(*) -with boot up info (b) -with backup info
DGS-3620-28TC:admin#config firmware image c:/new.had boot_up
Command: config firmware image c:/new.had boot_up
Success.
DGS-3620-28TC:admin#show boot_file
Command: show boot_file
Bootup Firmware : /c:/new.had
Bootup Configuration : /c:/config.cfg
DGS-3620-28TC:admin#reboot
Command: reboot
Are you sure you want to proceed with the system reboot?(y/n)

Убедиться в успешности произведённого обновления можно также с помощью команды show switch (часть вывода удалена).

DGS-3620-28TC:admin#show switch
Command: show switch
Device Type : DGS-3620-28TC Gigabit Ethernet Switch
Boot PROM Version : Build 1.00.012
Firmware Version : Build 1.00.038

Стоит также отметить, что смена прошивки возможна не только для одного конкретного коммутатора, но также и для их группы. В этом случае необходимо специально указывать идентификатор устройства, для которого производится обновление.

DGS-3620-28TC:admin#download firmware_fromTFTP sr src_file new.had unit ?
Command: download firmware_fromTFTP sr src_file new.had unit
Next possible completions:
<unit_id>

Аналогичных результатов можно добиться с помощью веб-интерфейса, где требуется обратиться к пункту Download Firmware меню Tools.

После того, как файл выгружен на коммутатор, необходимо сохранить текущую конфигурацию и перезагрузить устройство.

Убедиться в успешности проведённого обновления можно с помощью стартовой странички устройства.

На этом мы завершаем рассмотрение процедуры обновления микропрограммного обеспечения коммутатора D-Link DGS-3620-28TC и переходим к изучению его программных возможностей.

Обзор веб-интерфейса

Кроме заявленной во введении функции VLAN Translation коммутатор D-Link DGS-3620-28TC обладает ещё огромным набором разнообразных возможностей, к беглому рассмотрению которых мы и приступаем. При входе запрашивается логин и пароль. При использовании современных прошивок оба эти поля при первом входе необходимо оставить пустыми.

После ввода логина и пароля администратор попадает на стартовую страничку устройства, где представлены краткие сведения о самом устройстве и поддерживаемых протоколах.

Группа меню System Configuration позволяет администратору управлять настройками времени на коммутаторе, изменять базу данных пользователей, задавать параметры стекирования и журналирования. Также здесь можно объединять физические порты в группы.

Отдельно хотелось бы упомянуть о подгруппе Port Configuration, позволяющей управлять физическими параметрами работы сетевых интерфейсов коммутатора. Если оптические SFP-модули обладают поддержкой DDM (Digital Diagnostic Monitoring), то доступ к ней администратор может получить с помощью пунктов одноимённой подгруппы.

Коммутатор D-Link DGS-3620-28TC не имеет поддержки PoE (Power over Ethernet), однако при включении стекирования соответствующая подгруппа появляется в меню, что объясняется возможностью добавления в стек коммутатора с поддержкой PoE.

Параметры доступа к коммутатору для управления собраны в группе Management. D-Link DGS-3620-28TC поддерживает как внеполосное, так и внутриполосное управление. Также в этой группе расположена подгруппа Power Saving, позволяющая изменить параметры сбережения электроэнергии.

Подгруппа VLAN группы L2 Features позволяет администратору определять принадлежность к той или иной виртуальной сети на основе тэгов, портов, MAC или IP-адресов, протоколов сетевого уровня. Настройки протокола распространения информации о виртуальных сетях GVRP, супер виртуальных сетях, голосовых и приватных VLAN также представлены в этой подгруппе. В принципе, принадлежность к голосовым виртуальным сетям может быть также определена с помощью подгруппы LLDP.

Параметры работы технологии QinQ и протокола связующего дерева собраны в подгруппах QinQ и Spanning Tree той же группы. Приятной возможностью коммутатора D-Link DGS-3620-28TC стало наличие функции трансляции номеров виртуальных сетей, то есть когда один VID, приходящий через транковый порт, заменяется другим VID.

Агрегация физических портов в один логический производится с помощью подпункта Link Aggregation того же пункта меню. Для поддержки агрегированного интерфейса используется протокол LACP.

Таблица MAC-адресов и параметры её работы доступны администратору в подгруппе FDB.

Настроить групповую рассылку можно с помощью подгрупп L2 Multicast Control и Multicast Filtering.

Подпункт ERPS Settings предназначен для организации кольцевых топологий в сети Ethernet без использования протокола STP, но с применением более перспективного решения – ERPS (Ethernet Ring Protection Switching (ITU-T G.8032)), обеспечивающего время восстановления работоспособности сети менее 50мс.

Коммутатор D-Link DGS-3620-28TC позволяет сетевым администраторам подключать к нему сервера, нагрузка между которыми балансируется с использованием технологии NLB (Network Load Balancing). Соответствующая настройка доступна в подпункте NLB FDB Settings.

Получение очень точного времени производится с помощью протокола PTP, опции которого собраны в одноимённой подгруппе.

Управление статической маршрутизацией производится с помощью первых четырёх подпунктов группы L3 Features. Статические маршруты для группового вещания могут быть заданы в подпункте Static Multicast Route Settings.

Тестируемый L3-коммутатор поддерживает маршрутизацию по условию, соответствующая настройка доступна в подпункте Policy Route Settings той же группы.

Приоритет маршрута, полученного через разные протоколы динамической маршрутизации, задаётся с помощью административной дистанции, изменить которую можно с помощью подпункта Route Preference Settings группы L3 Features.

Правила балансировки нагрузки между одинаковыми (с точки зрения OSPF) маршрутами можно изменить в подпункте ECMP Algorithm Settings.

Передача маршрутов между различными протоколами маршрутизации производится с помощью подпунктов подгруппы Route Redistribution.

Управление туннелями 6to4, ISATAP и GRE производится с помощью подгруппы IP Tunnel.

Доступ к параметрам работы протоколов динамической маршрутизации OSPF, RIP и BGP можно получить с помощью одноимённых подгрупп. Настройка аутентификации OSPF производится в подпункте MD5 Settings.

Настройка маршрутизации для группового трафика производится с использованием элементов подгруппы IP Multicast Routing Protocol, а также с помощью подпункта IGMP Static Group Settings.

Правильной практикой построения сети является использование такой топологии, в которой все важные элементы продублированы. Такое дублирование можно провести с помощью протокола VRRP, настройка которого представлена в одноимённой подгруппе.

Подгруппа IP Route Filter позволяет администратору указать правила распространения маршрутной информации об определённых подсетях.

Пункт URPF Settings предназначен для включения на определённых физических портах функции защиты от спуфинга (URPF – Unicast Reverse Path Forwarding).

Настройки протокола 802.1p, параметры ограничения трафика и прочие опции, связанные с обеспечением качества обслуживания, собраны в группе QoS.

Управление списками доступа производится с помощью подпунктов группы ACL. Приятной опцией является возможность фильтрации трафика, обрабатываемого самим коммутатором.

Группа Security отвечает за работу с протоколом 802.1X, RADIUS аутентификацию, привязку IP и MAC адресов к порту, списки доступа MAC-уровня, аутентификацию пользователя по протоколу HTTP, защиту от сетевых атак, обнаружение петель, доступ администратора к коммутатору.

Кроме выполнения основных функций (коммутация и маршрутизация) D-Link DGS-3620-28TC может выполнять также целый ряд вспомогательных, заменяя собой ряд слабонагруженных серверов в сети. К числу таких функций можно отнести возможность работы устройства в качестве DHCP-сервера и ретранслятора для четвёртой и шестой версий протокола IP, DNS посредника, SNTP-сервера. Для доступа к указанным функциям необходимо обратиться к группе Network Application. Также здесь можно просмотреть содержимое встроенной флеш-памяти и выполнить некоторые операции с ней. Стоит также отметить, что подпункт UDP Helper пункта UDP позволяет настроить проброс определённых UDP-дейтаграмм на специализированный сервер.

Кабельная диагностика доступна в группе OAM, здесь же можно изменить параметры, относящиеся к поддержке стандарта 802.1ag.

Пункты подгруппы Utilization группы Monitoring отображают загрузку процессора, оперативной и флеш-памяти устройства. Здесь же можно посмотреть использование физических портов. Статистические сведения о работе портов представлены в подгруппе Statistics.

Коммутатор D-Link DGS-3620-28TC поддерживает SPAN и RSPAN сессии, соответствующие настройки доступны в подгруппе Mirror.

Для настройки sFlow необходимо обратиться к одноимённой подгруппе.

Проверить связность сети можно с помощью подгруппы Ping и пункта Trace Route.

Просмотреть температуры внутри корпуса, проверить скорость вращения вентиляторов, а также установить наличие иных аварийных событий можно с помощью подпункта Peripheral.

На этом мы завершаем рассмотрение веб-интерфейса коммутатора и переходим к изучению возможностей интерфейса командной строки.

Командная строка

Для доступа к командной строке устройства допустимо использование протоколов telnet и SSH, которые должны быть разрешены в соответствующих пунктах веб-интерфейса.

Мы не станем подробно описывать все возможности командной строки коммутатора, отметим лишь, что производитель считает такой инструмент настройки более гибким. Практически все команды можно отнести к нескольким крупным группам: команды очистки или сброса текущего состояния – clear, команды настройки – config, создания и удаления виртуальных объектов – create и delete, отладки – debug, включения и отключения – enable и disable, а также просмотровые – show. Полный список команд мы вынесли в отдельный файл.

Так, например, нас заинтересовала команда show utilization dram, отображающая занятость оперативной памяти. Из её вывода становится ясно, что коммутатор DGS-3620-28TC не может быть использован для получения BGP full-view, насчитывающую на сегодняшний день около полумиллиона записей.

DGS-3620-28TC:admin#show utilization dram
Command: show utilization dram
DRAM utilization :
Total DRAM : 262144 KB
Used DRAM : 253073 KB
Utilization : 96 %

Выяснить, кто управляет коммутатором в данный момент можно с помощью команды show session.

DGS-3620-28TC:admin#show session
Command: show session
ID Live Time From Level User
--- ------------ --------------------------------------- ----- ---------------
8 08:47:34.070 Serial Port login Anonymous
24 00:21:29.120 172.17.35.36 admin Anonymous
Total Entries: 2

Чтобы просмотреть мостовую таблицу, необходимо выполнить команду show fdb. В нашем случае мостовая таблица была пуста.

DGS-3620-28TC:admin#sho fdb
Command: show fdb
Unicast MAC Address Aging Time = 300
VID VLAN Name MAC Address Port Type Status
---- -------------------------------- ----------------- ----- ------- -------
1 default 84-C9-B2-1F-BE-00 CPU Self Forward
Total Entries: 1

Информация о работающих службах представлена в выводе команды show switch.

DGS-3620-28TC:admin#show switch
Command: show switch
Device Type : DGS-3620-28TC Gigabit Ethernet Switch
MAC Address : 84-C9-B2-1F-BE-00
IP Address : 10.90.90.90 (Manual)
VLAN Name : default
Subnet Mask : 255.0.0.0
Default Gateway : 0.0.0.0
Boot PROM Version : Build 1.00.016
Firmware Version : Build 2.50.017
Hardware Version : A1
Firmware Type : EI
Serial Number : PVXF1B8000113
System Name :
System Location :
System Uptime : 5 days, 8 hours, 50 minutes, 28 seconds
System Contact :
Spanning Tree : Enabled
GVRP : Disabled
IGMP Snooping : Disabled
MLD Snooping : Disabled
RIP : Disabled
RIPng : Disabled
DVMRP : Disabled
PIM : Disabled
PIM6 : Disabled
OSPF : Disabled
OSPFv3 : Disabled
BGP : Disabled
VLAN Trunk : Disabled
Telnet : Enabled (TCP 23)
Web : Enabled (TCP 80)
SNMP : Disabled
SSL Status : Disabled
SSH Status : Enabled
802.1X : Disabled
Jumbo Frame : Off
CLI Paging : Enabled
MAC Notification : Disabled
Port Mirror : Disabled
SNTP : Disabled
DHCP Relay : Disabled
DNSR Status : Disabled
VRRP : Disabled
HOL Prevention State : Enabled
Syslog Global State : Disabled
Single IP Management : Disabled
Password Encryption Status : Disabled
DNS Resolver : Disabled

Кроме указанных групп команд существует ещё и ряд других системных вызовов, не относящихся напрямую к той или иной группе. Так, например, с помощью команд ping и traceroute можно проверить связность сети.

DGS-3620-28TC:admin#ping 8.8.8.8
Command: ping 8.8.8.8
Reply from 8.8.8.8, time=10ms
Reply from 8.8.8.8, time=10ms
Reply from 8.8.8.8, time=10ms
Reply from 8.8.8.8, time=10ms
Ping Statistics for 8.8.8.8
Packets: Sent =4, Received =4, Lost =0

В разделе тестирования мы будем собирать схему для проверки работоспособности функции VLAN translation, для чего будем использовать веб-интерфейс устройства. Того же самого можно добиться и с применением командной строки.

DGS-3620-28TC:admin#create vlan_translation ports 8 replace cvid 3 svid 2 priority 0
Command: create vlan_translation ports 8 replace cvid 3 svid 2 priority 0
Success.
DGS-3620-28TC:admin#show vlan_translation
Command: show vlan_translation
Port CVID SPVID Action Priority
----- -------- -------- ------- ---------
8 3 2 Replace 0
14 3 2 Replace -
Total Entries: 2

Сохранение настроек производится с помощью команды save.

DGS-3620-28TC:admin#save
Command: save
Saving all configurations to NV-RAM.......... Done.

На этом мы завершаем беглое рассмотрение возможностей интерфейса командной строки коммутатора D-Link DGS-3620-28TC и переходим к его тестированию.

Тестирование

Данный раздел мы традиционно начинаем с установления времени загрузки устройство, под которым мы понимаем интервал времени, прошедший с момента подачи питания на коммутатор, до получения первого эхо-ответа по протоколу ICMP. D-Link DGS-3620-28TC загружается за 35 секунд, что является неплохим значением.

Второй тест – проверка защищённости устройства, выполняемый нами с использованием сканера сетевой безопасности Positive Technologies XSpider 7.7 (Demo build 3100). Сканирование производилось со стороны интерфейса управления. Всего было обнаружено два открытых порта: TCP-23 (Telnet) и TCP-443 (HTTP SSL). Наиболее интересные обнаруженные сведения представлены ниже.

Обычно современные коммутаторы без проблем справляются с задачей передачи фреймов на скорости среды, поэтому мы не стали измерять производительность устройства при выполнении коммутации и маршрутизации. Вместо этого мы провели измерения задержки, вносимой DGS-3620-28TC при коммутации и маршрутизации для фреймов размером 100, 400, 1400 и 1518 байт. Тесты проводились при различной загрузке интерфейсов на скорости подключения в 1 Гбит/с. Основные параметры использованного оборудования представлены ниже.

Компонент ПК Ноутбук
Материнская плата ASUS Maximus V Extreme ASUS M60J
Процессор Intel Core i7 3770K 3.5 ГГц Intel Core i7 720QM 1.6 ГГц
Оперативная память DDR3 PC3-10700 SEC 32 Гбайта DDR3 PC3-10700 SEC 16 Гбайт
Сетевая карта Intel Gigabit CT Desktop Adapter Atheros AR8131
Операционная система Windows 7 x64 SP1 Rus Windows 7 x64 SP1 Rus

На диаграммах ниже представлены задержки на коммутацию и маршрутизацию, вносимые коммутатором D-Link DGS-3620-28TC.

На обоих графиках задержки при передаче фреймов размером 400 байт ощутимо больше задержек, наблюдаемых для фреймов других размеров. Мы не можем объяснить полученный результат, однако даже задержка для 400-байтных кадров находится в пределах нормы. Средняя задержка, вносимая тестируемым L3-коммутатором, составляет примерно 4 мкс, что, на наш взгляд, является неплохим результатом для устройств подобного класса. При увеличении загрузки сетевых интерфейсов, через которые осуществлялась передача тестовых фреймов, задержка также незначительно увеличивалась, оставаясь в допустимых пределах. Полученные данные лучше тех, что мы наблюдали для коммутаторов Cisco Catalyst 3750G ранее.

Одной из интересных и новых для нас возможностей стала функция VLAN translation, являющаяся частью механизма QinQ. Суть VLAN translation состоит в том, что с её помощью можно заменять в тегированных кадрах одно значение VID на другое, то есть переопределять принадлежность к VLAN кадра, полученного через транковый порт. Для проверки работы данного функционала была собрана схема, представленная ниже. Хотелось бы сразу отметить, что подобной цели можно было бы добиться путём установки разных значений Native VLAN на противоположных концах транка, но такая схема работала бы лишь для одной единственной виртуальной сети, тогда как VLAN translation позволяет производить замену сразу для нескольких VID.

Дополнительным требованием с нашей стороны стало участие всех трёх коммутаторов в STP, что, на наш взгляд, необходимо для полноценной работы сети. Так как STP в его классическом виде безнадёжно устарел, единственным выбором стало использование MST. При пробросе через DGS-3620-28TC BPDU Cisco PVST+ происходило блокирование портов, так как коммутаторы Cisco Catalyst видели BPDU одной виртуальной сети внутри фреймов с тегами другой виртуальной сети. Чтобы не усложнять конструкцию, мы использовали единственный экземпляр STP – MST0. В этот экземпляр были добавлены все существующие на коммутаторах виртуальные сети. Со стороны коммутаторов Cisco Catalyst была произведена нижеследующая настройка.

left(config)#spanning-tree mode mst
left(config)#spanning-tree mst configuration
left(config-mst)#instance 0 vlan 1-4094

На стороне левого коммутатора Cisco Catalyst была создан VLAN 2 и виртуальный интерфейс SVI со следующими параметрами.

interface Vlan2
ip address 192.168.1.1 255.255.255.252
end

На правом коммутаторе – VLAN 3 и соответствующий виртуальный интерфейс.

interface Vlan3
ip address 192.168.1.2 255.255.255.252
end

Между коммутатором C3750G (слева) и DGS-3620-28TC был поднят транк, через который со стороны Cisco Catalyst пропущена виртуальная сеть 2. Для коммутатора C2960 (справа) были выполнены аналогичные настройки, но только с разрешением виртуальной сети 3.

interface GigabitEthernet1/0/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2
switchport mode trunk
load-interval 30
end

Теперь рассмотрим настройки DGS-3620-28TC. На транковых портах были разрешены VLAN 2 и 3.

Необходимо также задать роль порта, указать выходной TPID, а также включить QinQ.

Теперь зададим саму трансляцию идентификаторов виртуальных сетей.

Не стоит также забывать и о настройках Spanning Tree.

Проверкой работоспособности собранной схемы стало успешное хождение ICMP эхо-запросов между SVI-интерфейсами коммутаторов Cisco Catalyst.

right#sho ip int bri | i up
Vlan3 192.168.1.2 YES manual up up
GigabitEthernet0/1 unassigned YES unset up up
right#ping 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/9 ms
right#

Совместную работу с протоколом Spanning Tree мы проверили, увеличив значение приоритета для граничных коммутаторов, оставив без изменений настройки DGS-3620-28TC. Увеличение приоритета коммутатора снижает его шансы стать корневым в дереве STP. Таким образом в качестве корневого коммутатора должен был быть выбран D-Link DGS-3620-28TC, в чём можно убедиться просмотреть состояние коммутаторов Catalyst для соответствующих виртуальных сетей.

left#sho spanning-tree vlan 2
MST0
Spanning tree enabled protocol mstp
Root ID Priority 32768
Address 84c9.b21f.be00
Cost 20000
Port 1 (GigabitEthernet1/0/1)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 61440 (priority 61440 sys-id-ext 0)
Address 04fe.7fc5.9780
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi1/0/1 Root FWD 20000 128.1 P2p Bound(RSTP)

right#sho spanning-tree vlan 3
MST0
Spanning tree enabled protocol mstp
Root ID Priority 32768
Address 84c9.b21f.be00
Cost 20000
Port 25 (GigabitEthernet0/1)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 61440 (priority 61440 sys-id-ext 0)
Address 88f0.77dc.1880
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi0/1 Root FWD 20000 128.25 P2p Bound(RSTP)

Так как настройка оборудования и проверка обсуждаемого функционала заняло у нас много времени, мы решили представить нашим читателям полные конфигурационные файлы для левого и правого коммутаторов, а также для D-Link DGS-3620-28TC.

Коммутатор D-Link DGS-3620-28TC позволяет ограничить скорость пользовательского трафика, передаваемого через определённый порт (QoS-Bandwidth Control-Bandwidth Control Settings), мы решили проверить, насколько заданные значения скорости соответствуют реальным скоростям передачи пользовательских данных. На диаграмме ниже обе оси имеют логарифмический масштаб.

Также мы решили проверить работу функции агрегации физических каналов в логический. Для этого в качестве второго коммутатора мы использовали модель Cisco Catalyst 2960. Проверка производилась с использованием виртуальной сети 2, которая была создана на обоих коммутаторах. На коммутаторе DGS-3620-28TC мы создали интерфейс в VLAN2 с IP-адресом 192.168.2.1/24 (Management-IP Interface-Interface Settings), на Catalyst 2960 создали SVI-интерфейс также во второй виртуальной сети и назначили IP-адрес 192.168.2.2/24.

Порты 21 и 22 коммутатора DGS-3620-28TC были добавлены в транки с разрешённым VLAN2 (L2 Features-VLAN-802.1Q VLAN Settings). Аналогичные действия были проведены на коммутаторе Catalyst 2960 для портов Fa0/21 и Fa0/22.

С помощью подпунктов Port Trunking Settings и LACP Port Settings группы L2 Features-Link Aggregation мы создали Port-Channel 1, в который входят порты 21 и 22. Балансировка осуществляется по IP-адресам отправителя и получателя.

На стороне Catalyst 2960 были выполнены аналогичные настройки. В представленном ниже листинге находятся только команды, непосредственно относящиеся к текущему тесту.

port-channel load-balance src-dst-ip
vlan 2
name up_vlan
interface Port-channel1
switchport trunk allowed vlan 2
switchport mode trunk
interface FastEthernet0/21
switchport trunk allowed vlan 2
switchport mode trunk
load-interval 30
channel-protocol lacp
channel-group 1 mode active
spanning-tree portfast trunk
interface FastEthernet0/22
switchport trunk allowed vlan 2
switchport mode trunk
load-interval 30
channel-protocol lacp
channel-group 1 mode active
spanning-tree portfast trunk
interface Vlan2
ip address 192.168.2.2 255.255.255.0
load-interval 30

Успешное создание логического канала отображается в выводе команды show etherchannel summary, введённой на коммутаторе Cisco Catalyst 2960.

2960#sho etherchannel summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) LACP Fa0/21(P) Fa0/22(P)

Также убедиться в работоспособности построенного канала можно с помощью ICMP эхо-запросов, отправляемых с любого из коммутаторов. Пример такой отправки с коммутатора DGS-3620-28TC представлен ниже (Monitoring-Ping-Ping Test).

В качестве финального теста для коммутатора D-Link DGS-3620-28TC мы выбрали проверку работоспособности функционала LLDP MED, позволяющего подключать к порту коммутатора IP-телефон так, чтобы сам телефон был в одной виртуальной сети, а ПК, подключенный через телефон, - в другой. В этом случае IP-телефон выполняет функции моста. Для проверки мы использовали телефоны Avaya one-X Deskphone 9620L и 9650. Порт коммутатора, к которому подключается телефон, настраивается в качестве обычного порта доступа виртуальной сети для ПК. Дополнительно к этому должны быть введены следующие команды.

enable lldp
config lldp_med ports 11 med_transmit_capabilities all state enable
enable voice_vlan vlanid 3
config voice_vlan ports 11 state enable

Хотелось бы обратить внимание читателей на то, что мы подключали телефон к порту №11, а VLAN 3 использовался в качестве голосовой виртуальной сети, то есть при повторении указанных команд потребуется заменить номер порта и виртуальной сети на те, что используются в реальной сети.

Проверить успешность подключения телефона можно с помощью команды show voice_vlan lldp_med voice_device, вывод которой представлен ниже.

DGS-3620-28TC:admin#show voice_vlan lldp_med voice_device
Command: show voice_vlan lldp_med voice_device
Index : 1
Local Port : 11
Chassis ID : 172.16.99.249
Port ID Subtype : MAC Address
Port ID : 3C-B1-5B-4B-9C-C7
Create Time : 7/25/2013 06:38:37
Remain Time : 98 Seconds
Total Entries : 1

Аналогичные сведения можно получить и с помощью пункта L2 Features-VLAN-Voice VLAN-Voice VLAN LLDP-MED Voice Device веб-интерфейса.

Полностью убедиться в правильной настройке оборудования можно совершив тестовый звонок с телефона и установив наличие доступа к остальной части сети у ПК, подключенного к телефону.

На этом мы завершаем тестирование коммутатора D-Link DGS-3620-28TC и переходим к подведению итогов.

Заключение

В целом мы остались довольны протестированным гигабитным L3 коммутатором D-Link DGS-3620-28TC, возможностей которого вполне хватит для успешной работы на уровнях доступа и агрегации крупных сетей, а также и в ядрах сетей небольших и средних компаний. Более богатыми возможностями, по сравнению с веб-интерфейсом, обладает интерфейс командной строки, не являющийся cisco-like, что поначалу у нас вызывало незначительные затруднения, однако в процессе работы мы смогли легко адаптироваться к представленному синтаксису.

Сильные стороны DGS-3620-28TC перечислены ниже.

  • Богатый функционал.
  • Поддержка IPv6.
  • Возможность выполнения функций DHCP-сервера с поддержкой нескольких дополнительных опций.
  • Поддержка SNMPv3.
  • Возможность как внутриполосного, так и внеполосного управления.
  • Поддержка функции VLAN translation.
  • Наличие LLDP MED.
  • Возможность виртуального стекирования.

К сожалению, мы не можем не указать и на обнаруженные недостатки.

  • Немного заторможенный веб-интерфейс.
  • Не самый простой интерфейс командной строки.

На момент написания статьи средняя цена на коммутатор D-Link DGS-3620-28TC в интернет-магазинах Москвы составляла 75000 рублей.

Автор и редакция благодарят проект Anticisco за помощь в проведении тестирования.

Добавить комментарий


Защитный код
Обновить